6 Comments

  1. MiluoZ
    2015年2月6日 @ 14:15

    很棒~从您这里获得了很大的帮助

    Reply

  2. dahuang0210
    2016年11月14日 @ 15:57

    Hi~謝謝博主的經驗分享~我有一個問題不知道博主是否可以解答?在Yosemite之後,R在安裝package的時候總會出現無法讀取R_X11.so的錯誤,雖然不影響實際的安裝和應用,但是強迫症看起來真的很鬧心。我有查到這個問題的發生是因為Yosemite似乎是從系統組件中刪除了X11系列組件,所以需要單獨安裝XQuartz支持庫。但是即便安裝之後,明明在系統請求的路徑上已經有了X11文件,但是還是讀不到這個組件。我就停留在這裡了,不知道博主是否有遇到過這個問題。謝謝!

    Reply

    • ern
      2016年11月14日 @ 16:01

      我没有遇到这个错误,可能因为我在安装R前已经安装了X11.您试下先安装X11以后,再安装R呢?另外,要拿最新版的X11安装包。

      Reply

      • dahuang0210
        2016年11月14日 @ 16:14

        謝謝這麼快的回覆!我確實是裝的最新的2.7.11,也是按照這個順序安裝的,但是依然報錯。而且這個問題還不是我一台機器上是這樣,同學的機器也全部如此。所以一直很困惑~

        Reply

        • ern
          2016年11月14日 @ 16:17

          恰好在电脑边收到信息而已,呵呵。
          R也是最新版么?
          另外帮你搜索了一下,看看这个链接能否帮到你:http://stackoverflow.com/questions/26489928/cant-load-x11-in-r-after-os-x-yosemite-upgrade

          Reply

          • dahuang0210
            2016年11月14日 @ 16:23

            是的,R也是~這個答覆我也有參考過,他解決的應該就是確認在指定路徑是否確實存在R_X11.so這個文件,然後依然如故。也是沒輒了~非常感謝您~

            Reply

发表评论

电子邮件地址不会被公开。 必填项已用*标注